Issue with Google Apps for Education
Incident Report for Colby College IT Services
Resolved
The issue with Google Apps for Education has been successfully resolved by the vendor. If you are still experiencing an issue, please contact the ITS Support Center at support@colby.edu or 207-859-4222.
Posted Mar 11, 2024 - 08:49 EDT
Investigating
ITS is investigating an issue with Google Apps for Education (email, calendar, docs, etc) and will provide more information regularly via https://its-status.colby.edu.
Posted Mar 11, 2024 - 08:18 EDT
This incident affected: Google Apps (Google Apps Calendar, Google Apps Docs, Google Apps Drive, Google Apps Hangouts, Google Apps Sheets) and Colby E-mail.