Issue with external telephone calling
Incident Report for Colby College IT Services
Resolved
The issue with external telephone calling has been successfully resolved. If you are still experiencing an issue, please contact the ITS Support Center at support@colby.edu or 207-859-4222
Posted May 08, 2023 - 09:35 EDT
Investigating
ITS is investigating an issue with the ability to call external telephone numbers from on-campus and will provide more information regularly via https://its-status.colby.edu.
Posted May 08, 2023 - 09:00 EDT
This incident affected: Telephone Services.