Issue with Citrix Cloud/Workspace
Incident Report for Colby College IT Services
Resolved
The issue with Citrix Cloud/Workspace has been successfully resolved. If you are still experiencing an issue, please contact the ITS Support Center at 859-4222 or support@colby.edu
Posted Jul 22, 2022 - 09:23 EDT
Identified
ITS has identified an issue with Citrix Cloud/Workspace and is working with the vendor to resolve the problem as soon as possible. We will continue to provide updates via https://its-status.colby.edu.
Posted Jul 20, 2022 - 14:13 EDT
Investigating
ITS is investigating an issue with Citrix Cloud/Workspace and will provide more information regularly via https://its-status.colby.edu.
Posted Jul 18, 2022 - 16:38 EDT
This incident affected: Other Colby IT Services.