Issue with some Colby webpages
Incident Report for Colby College IT Services
Resolved
The issue with Colby web pages has been successfully resolved. If you are still experiencing an issue, please contact us via support@colby.edu or 207-859-4222.
Posted Feb 11, 2022 - 08:22 EST
Investigating
ITS is investigating an issue with some web pages not loading and will provide more information regularly via https://its-status.colby.edu.
Posted Feb 11, 2022 - 07:43 EST
This incident affected: Colby Websites (Colby Main Website, MyColby).